
Loreen V Haakonson
Cramsession™ for Microsoft Front Page 98

Loreen V Haakonson
This study guide will help you to prepare for Microsoft exam 70-055, Designing and Implementing Web Sites using Microsoft FrontPage 98. Topics include Analyzing Business Requirements, Defining Web Site Technical Architectures, Designing and Creating Web Sites, and Testing and Managing Web Sites. 


Loreen V Haakonson
Notice:  While every precaution has been taken in the preparation of this material, neither the author nor BrainBuzz.com assumes any liability in the event of loss or damage directly or indirectly caused by any inaccuracies or incompleteness of the material contained in this document. The information in this document is provided and distributed "as-is", without any expressed or implied warranty. Your use of the information in this document is solely at your own risk, and Brainbuzz.com cannot be held liable for any damages incurred through the use of this material. The use of product names in this work is for information purposes only, and does not constitute an endorsement by, or affiliation with BrainBuzz.com. Product names used in this work may be registered trademarks of their manufacturers. This document is protected under US and international copyright laws and is intended for individual, personal use only. For more details, visit our

Loreen V Haakonson
legal page.

Loreen V Haakonson
Check for the newest version of this Cramsession

Loreen V Haakonson
Rate this Cramsession

Loreen V Haakonson
Feedback Forum for this Cramsession/Exam

Loreen V Haakonson
More Cramsession Resources:

Loreen V Haakonson
Search for Related Jobs

Loreen V Haakonson
IT Resources & Tech Library

Loreen V Haakonson
SkillDrill - skills assessment

Loreen V Haakonson
CramChallenge - practice questions

Loreen V Haakonson
Certification & IT Newsletters

Loreen V Haakonson
Discounts, Freebies & Product Info

Loreen V Haakonson
http://cramsession.brainbuzz.com/checkversion.asp?V=2451956&FN=microsoft/fp98.pdf

Loreen V Haakonson
http://cramsession.brainbuzz.com/cramreviews/reviewCram.asp?cert=FrontPage+98

Loreen V Haakonson
http://boards.brainbuzz.com/boards/vbt.asp?b=687

Loreen V Haakonson
http://jobs.brainbuzz.com/JobSearch.asp?R=&CSRE=

Loreen V Haakonson
http://itresources.brainbuzz.com

Loreen V Haakonson
http://skilldrill.brainbuzz.com

Loreen V Haakonson
http://www.cramsession.com/signup/default.asp#day

Loreen V Haakonson
http://www.cramsession.com/signup/

Loreen V Haakonson
http://www.cramsession.com/signup/prodinfo.asp

Loreen V Haakonson
© 2000 All Rights Reserved - BrainBuzz.com

http://www.cramsession.com/signup/prodinfo.asp
http://www.cramsession.com/signup/
http://www.cramsession.com/signup/default.asp#day
http://skilldrill.brainbuzz.com
http://itresources.brainbuzz.com
http://jobs.brainbuzz.com/BrowseJobSearchRes.asp?KW=%22Designing+Implementing+Web+Sites+with+Microsoft+Front+Page+98%22+OR+Designing+Implementing+Web+Sites+with+Microsoft+Front+Page+98
http://cramsession.brainbuzz.com/checkversion.asp?V=2451956&FN=microsoft/fp98.pdf
http://cramsession.brainbuzz.com/cramreviews/reviewCram.asp?cert=FrontPage+98
http://boards.brainbuzz.com/boards/vbt.asp?b=687
http://cramsession.brainbuzz.com/helpInfo/LegalStuff/default.asp
http://www.brainbuzz.com/
http://www.brainbuzz.com/
http://www.cramsession.com/


                                                                                             

Cramsession:  
Designing and Implementing Web Sites using Microsoft FrontPage 98 
 
 

 TM 

 

 
 

  

© 2000 All Rights Reserved – BrainBuzz.com 

 

1 

 

Contents: 

Contents: ....................................................................................................... 1 
Installation ..................................................................................................... 2 
HTML Essentials .............................................................................................. 2 

Customer Support Web Template contains these elements: ............................ 6 
Personal Web Template contains these elements: .......................................... 6 
Project Web Template contains these elements: ............................................ 7 

FrontPage Explorer .......................................................................................... 7 
FrontPage Editor.............................................................................................. 9 
Analyzing Business Requirements:..................................................................... 9 

Target Audience ..........................................................................................10 
Maintenance Requirements ...........................................................................10 
Security Considerations ................................................................................10 

Defining the Technical Architecture for a FP98 Web Site ......................................11 
Developing the Conceptual and Logical Design for a FP98 Web Site ......................12 
Developing a User Interface and User Services for a FP98 Web Site ......................13 
Establishing the Development Environment .......................................................13 
Creating User Services ....................................................................................13 
Testing a FP98 Web Site..................................................................................14 
Publishing a FP98 Web Site..............................................................................15 
Managing a FP98 Web Site ..............................................................................16 
Managing Access to a FP98 Web Site ................................................................16 
FP98 Server Extensions...................................................................................17 
 

 

 

 

 

 



                                                                                             

Cramsession:  
Designing and Implementing Web Sites using Microsoft FrontPage 98 
 
 

 TM 

 

 
 

  

© 2000 All Rights Reserved – BrainBuzz.com 

 

2 

 

Installation 

Minimum Requirements: (KB# Q178487) 

• 486 or higher CPU 
• 16 MB RAM; Windows 95/98 
• 32 MB RAM; Windows NT 
• 36 MB hard disk space 
• VGA or higher resolution video adapter 

Miscellaneous: 

• A connection to the Internet is not required to use FP98, however, 
installation will fail if 32-bit TCP/IP protocol stack is not installed on 
the target system. (KB# Q176742) 

• FP98 Setup will inspect your system for the presence of a Microsoft 
Web Server and prompt you to install FrontPage 97 Personal Web 
Server if it does not find one. 

HTML Essentials 

• You are expected to have some experience with HTML. Here are some basic 
tags and the functions that create them in FP98 (for complete information on 
HTML standards, visit http://www.w3c.org/): 

 

HTML TAG FUNCTION FP98 FUNCTION USED TO CREATE TAG 

<html></html> HTML 
Identifier 

Created automatically by FP98. Identifies formatted text document
as an HTML document 

<meta> Meta 
Information 

Hidden information used for identifying authoring software, HTTP 
Refreshes, search engine indexing, etc. "<meta 
name="GENERATOR"...> tag created by default. All other meta 
tags must be entered using File > Page Properties > Custom Tab > 
User Variables > Add in FP98 Editor. (KB# Q194310) 

<body></body> Body 
Identifier 

Identifies page content. Created automatically by FP98. All content 
entered into FP98 Editor Normal View will appear between these 
tags 

<p></p> Paragraph Pressing Enter in FP98 Editor creates new paragraph (KB# 
Q194246) 

<br> Line Break Pressing Shift + Enter in FP98 Editor creates Line Break 

<title></title> Page Title In FP98 Editor, right-click on page, select Page Properties, enter 
new Title or in FP98 Explorer, right-click on page in Navigation 

http://support.microsoft.com/support/kb/articles/Q178/4/87.ASP
http://support.microsoft.com/support/kb/articles/Q176/7/42.ASP
http://www.w3c.org/
http://support.microsoft.com/support/kb/articles/Q194/3/10.ASP
http://support.microsoft.com/support/kb/articles/Q194/2/46.ASP
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View and Rename (preferred) 

<a href=""></a> Anchor Creates a Hyperlink by highlighting text/selecting image and 
selecting Insert > Hyperlink in FP98 Editor, then enter relative or 
absolute URL 

<table></table> Creates 
Table 

Table is created in FP98 Editor by selecting Table > Insert Table 

<tr></tr> Table Row Created automatically when Insert Table is used or by selecting 
Table > Insert Rows or Columns > Rows in FP98 Editor 

<td></td> Table Data Cell Created automatically when Insert Table is used or by selecting 
Table > Insert Rows or Columns > Columns in FP98 Editor 

<!-- ... --> Comment Allows a comment to be placed inside HTML code. Is not rendered 
in the users browser - they must view the page source to see the 
comment. Select Insert > FrontPage Component > Comment to 
insert a comment. Note: FP98 inserts all WebBot components 
between comment tags so that incompatible browsers will ignore 
the WebBot as it would a comment. Newer browsers parse the 
comment tags and process directives that they are aware of. 

 

Important FP98 Features to understand (KB# Q193955) 

• Banners - Mainly used in conjunction with Navigation View, Navigation Bars 
and Shared Borders to provide consistency to a Web. When used with Shared 
Borders, the page title entered when creating a page in the Navigation View 
will appear as a text overlay on the graphical banner of your choice. Banners 
can be chosen from a pre-defined Theme or a custom banner can be used 
instead. (KB# Q174421) 

• Banner Ad Manager - Displays successive banner-sized images according to a 
timed schedule. Uses a Java class applet on the target system. The banner is 
linked to a pre-defined URL. Server Extensions are not required for this 
component to function. (KB# Q173438) 

• Cascading Style Sheets Support (CSS) - Created using <STYLE>...</STYLE> 
tags. Should only be used with version 4 or higher Netscape and IE browsers 
(IE3 support for CSS is limited). FP98 does not have a Style Sheets Wizard, 
but styles can be manually defined for some items by using the "Styles" 
button that appears on some dialog boxes in FrontPage Editor. (KB# Q179628 
and Q180827) 

• Database Region Wizard - Uses Active Server Pages (.ASP) technology. 
Requires an ODBC Data Source Name that is provided by your System 
Administrator. Database is accessed by means of an SQL Query String. Files 
created with the Database Region Wizard should be saved with the .ASP 
filename extension as they contain scripting that must be processed on the 

http://support.microsoft.com/support/kb/articles/Q193/9/55.ASP
http://support.microsoft.com/support/kb/articles/Q174/4/21.ASP
http://support.microsoft.com/support/kb/articles/Q173/4/38.ASP
http://support.microsoft.com/support/kb/articles/Q179/6/28.ASP
http://support.microsoft.com/support/kb/articles/Q180/8/27.ASP
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Web server. Save .ASP files in a directory with at least script permission or 
they will not work. (KB#s Q174008, Q174015 and Q175771) 

• Discussion Web Wizard - Builds a Web-based discussion forum with threaded 
messages for increased user interaction. Can be added as a sub-Web or 
integrated into an existing Web solution. (KB# Q250839) 

• Dynamic HTML (DHTML) - Allows Webmaster to add animation and visual 
effects to a Web page. Accessed through Format > Animation... and Format > 
Page Transition... menus in FrontPage Editor. Generally supported by version 
4 browsers and higher. Best support obtained by using IE - test all DHTML 
pages before deploying on a production server. (KB# Q173422) 

• Form Handling/Validation - FP98's built in form handling features use pre-
compiled CGI scripts allowing you to write your form results to file, e-mail 
them to a responsible party, or both. Validation can be either client or server 
side using JavaScript or VBScript. Using validation prevents users from 
submitting data that does not comply with the restrictions you have set in 
place. Confirmation forms can also be displayed using form field names. (KB# 
Q194088) 

• counts the number of times your page has been accessed, or "hit". Requires 
FrontPage Server Extensions on Web server. Five default styles to choose 
from. Can be reset to a higher/lower number or restricted to a fixed length. 
(KB# Q187773) 

• Include Page - WebBot Component that simplifies site management by 
inserting one HTML page inside another. Should be used when a Shared 
Border does not provide flexibility needed or when content needs to be 
inserted into a TABLE field. By default, Include Page will import everything 
between the <BODY>...</BODY> tags in the included document. 

• Insert HTML - FP98 has an extremely annoying habit of reformatting 
(Microsoft calls it "checking for correctness") all HTML code you manually 
enter using the HTML View in FrontPage Editor. If you want to stop FP98 from 
destroying a section of code, use Insert > FrontPage Component > Insert 
HTML in FrontPage Editor. Enter your HTML in the space provided and FP98 
will place it in your document between these tags "<!--webbot 
bot="HTMLMarkup" startspan -->...<!--webbot bot="HTMLMarkup" endspan -
->" 

• Internet Database Connector - Older technology that does not use Active 
Server pages. Queries an ODBC database by means of an Internet Database 
Connector (.IDC) file. Query results are returned by the Web server in an 
HTML extensions file (.HTX). (KB# Q174407) 

• Navigation Bars - Used with Navigation View and Shared Borders. Contains a 
list of text links or graphical buttons with text overlays. Navigation Bar 

http://support.microsoft.com/support/kb/articles/Q174/0/08.ASP
http://support.microsoft.com/support/kb/articles/Q174/0/15.ASP
http://support.microsoft.com/support/kb/articles/Q175/7/71.ASP
http://support.microsoft.com/support/kb/articles/Q250/8/39.ASP
http://support.microsoft.com/support/kb/articles/Q173/4/22.ASP
http://support.microsoft.com/support/kb/articles/Q194/0/88.ASP
http://support.microsoft.com/support/kb/articles/Q187/7/73.ASP
http://support.microsoft.com/support/kb/articles/Q174/4/07.ASP
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hyperlinks are managed by FP98. To add, remove, or rename items on a 
Navigation Bar, use the Navigation View in FrontPage Explorer. Microsoft 
recommends that you let FrontPage handle your navigation and that you 
should use this feature. (KB# Q180836) 

• Scheduled Image/Include Page - allows insertion of an image or HTML page 
that will be specified for a specified time or date. You can specify and 
alternate image/page to be displayed before and after the scheduled item. 
After scheduling a component, remember to Recalculate Hyperlinks in 
FrontPage Explorer or the feature will not  

• Scripting - FP98 includes a Scripting Wizard. Remember that when VBScript is 
used on the Web server, you are limited to only Microsoft Web servers but 
can use any browser. When VBScript is used on the Client Side, you are 
limited to Microsoft IE3 and higher.(KB# Q194063) 

• Search Form - Lets you add search capabilities to your Web. Searches all 
documents in your Web except for those stored in the "_private" folder. 
Integrated with Index Server on IIS4. Creates an .IDQ file which queries 
Index Sever; results returned as a .HTX file (stored in the "_derived" hidden 
directory). The .IDQ file is stored in the "_vti_bin" hidden folder in your Web. 
FP98 Uses a WAIS search engine and text indices stored in the "_vti_txt" 
hidden directory when Index Server is not present. (KB# Q194075 and 
Q194484) 

• Shared Borders - Used in conjunction with Banners, Navigational Bars and 
Navigation View to provide consistency to a Web. There are four borders that 
can be defined, top, bottom, left, and right. It is not possible to have two 
different items in a shared border in the same Web, (e.g. different copyright 
information for Marketing and Customer Support divisions in bottom Shared 
Border). Consider using Include Page feature or creating sub-Webs instead. 
(KB# Q173435) 

 
Tasks View - Multi-user To-do list and Enterprise feature of FP98.  

http://support.microsoft.com/support/kb/articles/Q180/8/36.ASP
http://support.microsoft.com/support/kb/articles/Q194/0/63.ASP
http://support.microsoft.com/support/kb/articles/Q194/0/75.ASP
http://support.microsoft.com/support/kb/articles/Q194/4/84.ASP
http://support.microsoft.com/support/kb/articles/Q173/4/35.ASP
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• Allows multiple Webmasters to maintain a site without duplication of effort by 
assigning tasks to individuals or groups. It is important to understand this 
feature thoroughly before writing exam 70-055. 

• Templates and Wizards - sets of predesigned documents that contain the 
structure, but not the content for new Webs or individual pages that are being 
created. 

• Themes - A pre-defined set of graphics (.GIF files) and Cascading Style 
Sheets documents that can be applied to a Web to give it consistency and a 
professional appearance. Themes View in FP Explorer sets properties for the 
entire Web whereas Themes properties for individual pages can be altered in 
FP Editor. Themes are stored in the "_themes" hidden folder in your Web. 
(KB# Q173421 and Q180821) 

• Visual SourceSafe Integration - Functions like RCS for UNIX. Automated by 
FP98 Server Extensions when enabled. When user opens a document, it is 
"checked out", preventing other users from accessing file. When user closes 
document, it is "checked (back) in" again. This prevents different users 
working on the same file at the same time and overwriting each other's 
changes. (KB# Q189368 and Q194544) 

 

FP98 Templates and Wizards (KB# Q173418) 

Customer Support Web Template contains these elements: 

• Welcome Page - Introductory document and table of contents 

• Bugs - Form for reporting bugs/errata in product 

• Download - Offers files for download 

• Discussion - Web-based threaded discussion board 

• Frequently Asked Questions 

• Search - let's visitors search site by keyword 

• Suggestions - Form for posting suggestions 

• What's New - Section for providing late-breaking news to site visitors 

 

Personal Web Template contains these elements: 

• Home - Introduction and table of contents 

• Interests - Place to list your hobbies/interests 

• Favorites - Area for placing links to other Web sites you like 

http://support.microsoft.com/support/kb/articles/Q173/4/21.ASP
http://support.microsoft.com/support/kb/articles/Q180/8/21.ASP
http://support.microsoft.com/support/kb/articles/Q189/3/68.ASP
http://support.microsoft.com/support/kb/articles/Q194/5/44.ASP
http://support.microsoft.com/support/kb/articles/Q173/4/18.ASP
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• Photo Album - A page to display your photographs to visitors 

 

Project Web Template contains these elements: 

• Home - Introduction, project overview and list of all changes to the Web site 

• Archive - Single document that contains links to project resources 

• Discussion - Web-based threaded discussion board 

• Members - Contact info for persons involved in the project 

• Schedule 

• Search - Allows visitors to search site contents by keyword 

• Status - Document that can be linked to status reports you create 

• Empty Web Template - there is nothing in this template, it is used for creating 
Webs from scratch. 

• Corporate Presence Wizard - walks the user through all of the steps necessary 
to create a corporate presence on the Internet. 

• Discussion Web Wizard - used for creating an interactive, threaded, Web-
based discussion board. 

 

FrontPage Explorer 

• A powerful tool used to manage an entire Web site. Not used for editing the 
properties of individual pages in the Web site (except for renaming pages in 
Navigation View). Used to create new Webs using one of three different 
methods: 

o Create an entire Web site from scratch 
o Create a Web using FP98 Wizards and Templates 
o Import an existing Web site (if site was authored with 

FrontPage, existing settings/themes will be imported - also 
works fine with sites authored using other means) 

Has seven different views: 

1. Folders - Displays a list of all files and folders in the current 
Web. Folders appear in left hand pane while subfolders and files 
appear in right hand pane (just like Windows Explorer) 
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2. All Files - Shows list of all files contained in site. Files are not 
separated by folder although folder info is displayed. This is the 
only view that allows you to find orphan files 

3. Navigation - Default view for sites created using FP98. Divided 
into two areas, Navigation Pane and Contents Pane. Navigation 
Pane shows flowchart like graphical representation of links 
between HTML documents in Web. Content Pane shows all files 
and folders in the current Web site 

4. Hyperlinks - Shows graphical view of linked objects in Web site. 
Direction of arrows indicate how objects are linked. Detail levels 
may be increased or decreased by clicking on the plus or minus 
signs. For internal documents only - external links are not 
displayed 

5. Hyperlink Status - Used for checking the status of internal and 
external hyperlinks. Green circles indicate links are OK. Yellow 
circles are for unchecked links and red circles denote broken 
links. Verified links are not displayed by default 

6. Themes - Used to assign a Theme to, or alter a Theme for a 
FP98 Web 

7. Tasks - A to-do list for multiple users. Action items are added to 
the Tasks listing and given a priority level. Tasks can be 
unlinked, or linked to specific objects/pages 

• Spell check feature under Tools menu can be used to check spelling of all 
pages in site at once and can also assign tasks to pages found to have errors. 

• Replace feature under Tools menu can be used to replace words or character 
strings throughout the entire site (e.g. After joining with Cramsession, it's 
decided by those in charge that changing all incidences of "Cramsession" to 
"Brainbuzz" in a 3000+ page Web is desirable for marketing). 

• If you're one of those companies that gets acquired every second week, 
consider entering your company name into your Web as a variable - Tools > 
Web Settings > Parameters. Variables are used by inserting a "Substitution" 
FP98 component into pages with FrontPage Editor. Changing a variable in 
FrontPage Explorer causes the referenced variable to change throughout 
entire Web. 

• Shared Borders and Themes properties for the entire Web are set in 
FrontPage Explorer. 

• To change the title of a page, right-click on it in Navigation View and change 
it's name, this will change it's <TITLE>...</TITLE> tag. (Author's note: 
Microsoft pushes the Navigation View feature heavily in all of their training 
material, but in real life I've yet to meet a Web developer who will admit to 
using it - I certainly don't.) (KB# Q173928) 

http://support.microsoft.com/support/kb/articles/Q173/9/28.ASP
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FrontPage Editor 

• Used to create/edit individual HTML pages. Cannot be used for managing the 
Web as a whole. 

• Has five different Views (can be toggled by using the small tabs appearing at 
lower left corner of FrontPage Editor window): 

1. Normal - standard WYSIWYG working space showing 
approximate look of page in progress. 

2. HTML - allows viewing and direct editing/tweaking of HTML 
code. 

3. Preview - simulation of a Web browser, used for previewing 
how page will look in a browser, testing mouseover effects, etc. 
(KB# Q174081) 

4. No Frames (frames only) - displays what nonframes users (i.e., 
those with antique browsers) will see. 

5. Frames Page HTML (frames only) - displays the raw HTML code 
of the frames document itself. 

• Shared Borders and Themes properties for the individual pages are set in 
FrontPage Editor. 

• Estimated loading time of document is always displayed in the bottom right 
hand corner of FrontPage Editor window. This estimation is based on 28.8 
modem speeds. 

 

Analyzing Business Requirements: 

Information Sharing Needs 

• Internal - addressed by an intranet Web solution. Content usually consists of 
org charts, reference materials, project status info, customer info, accounting 
data, sales projections, employee manuals, reports, etc. Discussion Web 
Wizard and Project Web Template are suggested for Internal info sharing 
needs. Usually confidential and requires that data is secured. 

• External - addressed by an extranet or Internet Web solution. Content usually 
consists of product info/availability/ordering, payment information, shipping 
status, service requests, info about company, etc. Corporate Presence Web 
Wizard or Customer Support Web Template suggested for External info 
sharing needs. 

 

http://support.microsoft.com/support/kb/articles/Q174/0/81.ASP


                                                                                             

Cramsession:  
Designing and Implementing Web Sites using Microsoft FrontPage 98 
 
 

 TM 

 

 
 

  

© 2000 All Rights Reserved – BrainBuzz.com 

 

10 

 

Target Audience 

• What types of browser is your audience using? Are you deploying to a mixed 
audience over the Internet or for a corporate intranet where all browsers have 
been standardized on Internet Explorer 4 (IE4) allowing you to use FP98's 
features that are proprietary to Microsoft browsers? 

• What type of network connections will your audience be using to connect to 
your site? Modem users accessing through the public Internet or broadband 
access via the corporate LAN?  

 

Maintenance Requirements 

• Whenever possible, use a database solution (Database Region Wizard) rather 
than static HTML pages - it will reduce the administrative overhead in 
maintaining a FrontPage Web. 

 

Security Considerations 

• When an Administrator is creating a new Web, he/she has the option to check 
the "Secure Connection Required (SSL)" and use Secure Sockets Layer (port 
443) to prevent unauthorized access to communications between the 
FrontPage client and Web server. This is the only way to protect passwords 
during authentication. (KB# Q194072) 

• Will organizational units within the company be maintaining their own sites? If 
so, consider creating sub-Webs under the Root Web. Sub-Webs can have 
different permissions assigned to them than the Root Web. (e.g. All 
computers but those belonging to the Research unit are denied access to the 
Research sub-Web.) (KB# Q176134) 

 

 

 

 

 

 

 

http://support.microsoft.com/support/kb/articles/Q194/0/72.ASP
http://support.microsoft.com/support/kb/articles/Q176/1/34.ASP
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Defining the Technical Architecture for a FP98 Web 
Site 

Support for FP98 features by Netscape and Internet Explorer: 

 

Features NN2 NN3 NC4 IE2 IE3 IE4 IE5

Active Channels - - - - - X X

ActiveX - - - - X X X

ASP - - - - X X X

Background Colors X X X X X X X

Background Images X X X X X X X

Banner Ad Manager X X X - X X X

Browser Plug-ins X X X - X X X

Client-side Scripts - X X - X X X

Collapsible Outlines - - - - - X X

Comment Tags X X X X X X X

Custom Font Colours X X X X X X X

Custom Font Faces - X X X X X X

Custom Font Sizes X X X X X X X

Dynamic HTML - - X - - X X

Forms X X X X X X X

Frames X X X - X X X

GIFs (animated) X X X - X X X

Hover Buttons X X X - X X X

Inline Audio/Video - X X - X X X

Java X X X - X X X

JavaScript X X X - X X X

Marquees - - - X X X X

Page Margins - - - - X X X

Page Transitions - - - - - X X
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Style Sheets - - X - - X X

Tables X X X - X X X

VBScript - - - - X X X

Legend: "X"=Supported, "-"=Not Supported 

 
• User registration forces users to register before accessing a protected Web. 

Only works in the Root Web. (KB# Q194156) 

• When working with images, always include a text description in the Alternate 
Representations field of the Image Properties dialog. For extremely large 
images, a smaller low resolution image can be entered in Alternative 
Representations. It will be loaded first and replaced with the larger image 
when it has finished loading. 

• Alternate text links should be provided for all navigational controls. 

• In FrontPage Explorer, make sure the validation script settings you select are 
compatible with the end user's browser. You can do this by right-clicking in 
the Navigation View and selecting Web Settings > Advanced. This is also 
accessible in FrontPage Explorer under Tools > Web Settings > Advanced. 
Javascript is selected by default. 

• Image maps can be set to server or client side. Choices for map styles are 
FrontPage, NCSA, CERN, and Netscape. 

 

Developing the Conceptual and Logical Design for a 
FP98 Web Site 

• Include Page or Scheduled Include Page/Image Components can be used for 
images or HTML that are the same throughout a Web but are sometimes 
changed or updated. 

• Use the Tasks View to assign Action Items to multiple Webmasters 
collaborating on a site in order to prevent duplication of effort. 

• Divide a site into Sub-webs with different administrators and access 
permissions to make it more manageable. (KB# Q194210 and Q194676) 

 

http://http://support.microsoft.com/support/kb/articles/Q194/1/56.ASP
http://support.microsoft.com/support/kb/articles/Q194/2/10.ASP
http://support.microsoft.com/support/kb/articles/Q194/6/76.ASP
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Developing a User Interface and User Services for a 
FP98 Web Site 

• Microsoft recommends using FP98's built in navigation tools rather than 
designing your own navigational scheme manually - less administrative 
overhead. (Author's note: This is important; it shows up often in the Microsoft 
Official Curriculum for both FP98 and FP2000). 

• Applying Themes to a site give it a more consistent and professional look. 
Sub-Webs can use a variation of the Root Web's Theme. 

• Use e-mail forms, discussion boards, suggestion pages and bug reports to add 
interactivity to a site by seeking user input. 

 

Establishing the Development Environment 

• FP98 comes with it's own Web server for testing locally before deploying 
content to a production Web server. This server is only appropriate for 
testing, it was not designed to be used by more than a handful of users.(KB# 
Q194101 and Q194229) 

 

Creating User Services 

• Forms are used to collect user input. Form results can be written to a text file 
or HTML file on the Web server or sent by e-mail to a designated recipient. 
Setting Form Field Validation allows you to restrict the type of input a user 
can enter into a form field. If the submitted data does not meet the 
restrictions, a client-side VBScript (IE only) or Javascript (both browsers), the 
user is prompted to try again. 

• Hidden fields are used to submit info unseen by the site visitor, like a form 
name. 

• Use FrontPage Explorer's Navigation View to map out the Navigation Scheme 
for your Web. 

• Defining channels allows a Webmaster to push data to site users. Launch the 
Channel Definition Wizard using Tools > Define Channel in FrontPage 
Explorer. (KB# Q173920, Q174055 and Q177079) 

• Background sound only works in IE. For Netscape users you will need to use a 
Javascript to do a browser level detect and send the right HTML code to the 
browser. (KB# Q193057) 

http://support.microsoft.com/support/kb/articles/Q194/1/01.ASP
http://support.microsoft.com/support/kb/articles/Q194/2/29.ASP
http://support.microsoft.com/support/kb/articles/Q173/9/20.ASP
http://support.microsoft.com/support/kb/articles/Q174/0/55.ASP
http://support.microsoft.com/support/kb/articles/Q177/0/79.ASP
http://support.microsoft.com/support/kb/articles/Q193/0/57.ASP
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Testing a FP98 Web Site 

• Webs should always be tested on a staging server before being published to a 
production Web server. 

• FrontPage 97 Personal Web Server cannot be used for testing .ASP scripts as 
it does not support ADO (Active Data Objects). If you are developing a site 
using .ASP scripts you must use Microsoft Personal Web Server 4.0 for 
Windows 95/98, Microsoft Peer Web Services for Windows NT 4.0 or Microsoft 
Internet Information Server 4.0 for Windows NT 4.0 Server. .ASP scripts will 
not function on non-Microsoft Web servers. (KB# Q194355) 

• Browse-time components will not work on disk-based Webs. You will need to 
publish to a Web Server with FrontPage Server Extensions installed to test 
pages using these features. This applies to the following FP98 features: (KB# 
Q173437 and Q194308) 

• Active Server Pages (ASP) 

o Discussion Form Handler 

o Internet Database Connector 

o Database Region Wizard 

o Hit Counter 

o Hover Button with a custom image 

o Registration Form Handler 

o Save Results Form Handler 

o Search Form 

 

• Always test your site on as many platforms with as many browsers as 
possible (use Preview in Browser command in FrontPage Editor on 
development system to access installed browsers) to find out what 
compatibility problems may arise for your users. Try different resolutions and 
colour depth settings on your test systems as well (e.g. an 800 pixel wide 
table goes off the viewable screen of a user at 640x480 screen resolution - 
resize table accordingly). 

 

 

 

http://support.microsoft.com/support/kb/articles/Q194/3/55.ASP
http://support.microsoft.com/support/kb/articles/Q173/4/37.ASP
http://support.microsoft.com/support/kb/articles/Q194/3/08.ASP
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The most important tool in FrontPage Editor for testing your Web 
site: 

 

 

 

Publishing a FP98 Web Site 

• Publishing moves your content from the server you are currently 
administering your Web from to a different server/servers. 

• Sites are published using Files > Publish FrontPage Web or the Publish Button 
in FrontPage Explorer toolbar (one-click publishing). Webs cannot be 
published from within FrontPage Editor. 

• Three publishing methods; one-click publishing, multisite publishing and FTP 
publishing. FP98 will first check for presence of FP98 Server Extensions, then 
will default to FTP method if it cannot find them and prompt user for FTP 
credentials. (KB# Q194092 and Q194093) 

• FP98 can be set to publish "changed pages only" or "entire site". 

• If publishing from behind a proxy server, use Tools > Options > Proxies in 
FrontPage Explorer to define the proxy server. It can be defined as either an 
IP address or NetBIOS name followed by a colon and then the port number 
(e.g. 192.168.1.100:8080 or WEBPROXY:8080) 

http://support.microsoft.com/support/kb/articles/Q194/0/92.ASP
http://support.microsoft.com/support/kb/articles/Q194/0/93.ASP
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Managing a FP98 Web Site 

• Using the Navigation View you can add new pages to your Web, shuffle 
existing pages around between directories without breaking existing links and 
change a page's title. 

• Periodically use the Hyperlink Status view in FrontPage Explorer to check for 
broken links, crucial for preventing "link rot". Remember that the Hyperlinks 
View only shows the relationship between internal documents on your Web, it 
does not tell you what links are broken. 

• Enable VisualSourceSafe to prevent users from overwriting each others work. 

• Change the editor used to open a certain file type by using the Tools > 
Options > Configure Editors Tab (e.g. change file association for .JPG so that 
it is opened using Adobe Photoshop instead of Paint Shop Pro.) 

• To find orphaned files or all files created by a single user, use the All Files 
View. (KB# Q202154) 

• Use Tools > Web Settings > Configuration Tab to change a FP98 Web's name 
and title. (KB# Q194089) 

 

Managing Access to a FP98 Web Site 

• Administrator privileges are needed to create, change, and delete FP98 Webs. 

• Security settings for the Web or Sub-web can be altered under Tools > 
Permissions in FrontPage Explorer. Administration, authoring and browser 
privileges can be granted on a User or Group basis. Permissions in sub-Webs 
can differ from the Root Web. (KB# Q194670) 

• An administrator can grant or block access to a Web on a user, group or 
machine basis. 

http://support.microsoft.com/support/kb/articles/Q202/1/54.ASP
http://support.microsoft.com/support/kb/articles/Q194/0/89.ASP
http://support.microsoft.com/support/kb/articles/Q194/6/70.ASP
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FP98 Server Extensions 

Supported Platforms: 
Platform  Operating System  Web Servers  

Intel x86 Microsoft Windows NT 4.0 Server Microsoft Internet Information Server 4.0 
Netscape Commerce Server 1.12  
Netscape Communications Server 1.12 
Netscape Enterprise 2.0 and 3.0 
Netscape FastTrack 2.0 

Intel x86 Microsoft Windows NT 4.0 
Workstation 

Microsoft Peer Web Services 

Intel x86 Microsoft Windows 95/98 Microsoft Personal Web Server 
Microsoft FrontPageÂ®  97 Personal Web 
Server 

Alpha Microsoft Windows NT 4.0 Server Microsoft Internet Information Server 4.0 

Alpha Microsoft Windows NT 4.0 
Workstation 

Microsoft Peer Web Services 

Alpha  Digital UNIX 3.2c, 4.0  Apache 1.1.3, 1.2.4, 1.2.5 
CERN 3.0  
NCSA1.5.2  
(1.5a or 1.5.1 are not supported) 
Netscape Commerce Server 1.12 
Netscape Communications Server 1.12 
Netscape Enterprise Server 2.0 and 3.0  
Netscape FastTrack 2.0 

Intel x86  BSD/OS 2.1 
BSD/OS 3.0 
Linux 3.0.3  
(Red Hat Software) 
SCO OpenServer  release 5* 
SCO UnixWare 7* 

same as above  

PA-RISC  HP/UX 9.03, 10.01  same as above  

RS6000  AIX 3.2.5, 4.x*  same as above  

Silicon 
Graphics  

IRIX 5.3, 6.2  same as above  

SPARC  SunOS 4.1.3, 4.1.4  same as above  
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• The following is a list of special files and directories maintained by Microsoft 
FrontPage 98: 

 

Folders Files Purpose 
_overlay *.gif Overlay files for FP98™s text on GIF and navigation 

button features. These files are transparent GIFs that 
are overlaid on top of base button or banner images to 
build a complete text on GIF or navigation button 
image. 

_derived *.htx, *.gif Dynamically generated by FP98 and can be recreated 
at any time, like *.htx files created by the FP98 Search 
Component (only with IIS with Microsoft Index Server) 
and composite text on GIF images (e.g., theme 
buttons and banners). 

_borders top.htm, left.htm, right.htm, 
bottom.htm 

Shared border definition files that are included into 
pages using shared borders. 

_themes *.gif, *.inf, *.css files for 
each theme 

FP98 themes storage. Each theme that is applied to 
the web is uploaded into a uniquely named subfolder 
of the _themes directory. Each theme consists of GIF, 
CSS, and INF files that define the theme. 

_fpclass *.class Compiled Java class files that implement the Banner 
Ad Manager and Hover Button FP98 components. 

_private   This folder is created in each FP98 web. It is intended 
to contain user files that are not browsable. Does not 
work on IIS servers. The good news is that Index 
Server will ignore any documents placed in this folder 
and not return them in site searches. 

shtml.dll 
shtml.exe 

Stub FP98 Server Extensions executables for runtime 
functionality. 

fpcount.exe Runtime portion of the FP98 Hit Counter component. 

_vti_bin 

*.idq Query files created by the FP98 Search component 
when using IIS with Microsoft Index Server. These files 
reside in the _vti_bin directory in order to get execute 
permissions. 

_vti_cnf For each HTML page and 
graphics file in a FrontPage 
web there is a configuration 
file of the same name.  

Each configuration page contains a set of name value 
pairs, identifying things like the last author to edit a 
page or the program associated with a file.  

_vti_log   Root web only. Only populated after the web 
administrator has enabled logging in the frontpg.ini or 
we<port>.cnf file. When active, an author.log file gets 
created here logging only FrontPage authoring and 
administration operations. 



                                                                                             

Cramsession:  
Designing and Implementing Web Sites using Microsoft FrontPage 98 
 
 

 TM 

 

 
 

  

© 2000 All Rights Reserved – BrainBuzz.com 

 

19 

 

_vti_map   Contains image map files. 

_vti_txt   Contains text indices for the WAIS search engine only. 
Not used by Index Server on IIS. 

 

• When planning a Web, consider whether or not the server hosting the 
production Web site will have FP98 Server Extensions installed. If not, the 
following FrontPage Components should not be used in your Web: (KB# 
Q194051) 

 

o Confirmation Field 

o Discussion Form Handler 

o FrontPage created server-side image maps 

o Hit Counter 

o Registration Form Handler 

o Save Results Form Handler 

o Scheduled Image 

o Scheduled Include Page Component 

o Search Form 

 
 
 

Special thanks to 

Sean McCormick 

for contributing this 

 Cramsession.  

 

 

 

 

 

http://support.microsoft.com/support/kb/articles/Q194/0/51.ASP
mailto:sean.mccormick@techie.com
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